[Spring Boot Tip] Errore @Valid con la versione 2.3.1

Se dovesse capitarvi di migrare un progetto Spring Boot alla versione 2.3.1 ricordatevi che spring-boot-starter-validation non è più incluso nello starter (perchè? boh!), quindi @Valid non funziona più e via alle bestemmie.

Per risolvere occorre aggiungere alle dipendenze

<dependency>
<groupId>org.springframework.boot</groupId>
<artifactId>spring-boot-starter-validation</artifactId>
</dependency>

Lascia una risposta

L'indirizzo email non verrà pubblicato. I campi obbligatori sono contrassegnati *

Utilizzando il sito, accetti l'invio dei cookies da parte nostra. Maggiori informazioni

Questo sito utilizza i cookies per fornire la migliore esperienza di navigazione possibile. Continuando ad utilizzarlo senza modificare le impostazioni o cliccando su "Accetta" acconsenti al loro utilizzo.

Chiudi